Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$
/
gm
Input 1
1
New
+89031231232 92912312-32 +7929 123 12 32 +8 929 12-312-32 +8 929 123-12-32
Substitution
+7 (\1) \2\3\4 \5\6 \7\8
+89031231232 92912312-32 +7929 123 12 32 +8 929 12-312-32 +8 929 123-12-32