#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^[0-9]{1,2}/[0-9]{1,2}/[0-9]{1,2}), ([0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{2}) - ([a-z0-9 \S]+?)(:| added|created group) ([a-z0-9 \S\n]+)?"
Local $sString = "3/22/16, 12:35 PM - Narayanaswamy Meetup Hsp: Guys Ranjit is proposing to have a Holi walk (not Holy walk) on Thursday 24-3-16. He will put up the proposal and if anyone wishes to join pl co-ordinate with Ranjit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")