const regex = new RegExp('(^[0-9]{1,2}/[0-9]{1,2}/[0-9]{1,2}), ([0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{2}) - ([a-z0-9 \\S]+?)(:| added|created group) ([a-z0-9 \\S\\n]+)?', '')
const str = `3/22/16, 12:35 PM - Narayanaswamy Meetup Hsp: Guys Ranjit is proposing to have a Holi walk (not Holy walk) on Thursday 24-3-16. He will put up the proposal and if anyone wishes to join pl co-ordinate with Ranjit`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}