// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^[0-9]{1,2}/[0-9]{1,2}/[0-9]{1,2}), ([0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{2}) - ([a-z0-9 \S]+?)(:| added|created group) ([a-z0-9 \S\n]+)?").unwrap();
let string = "3/22/16, 12:35 PM - Narayanaswamy Meetup Hsp: Guys Ranjit is proposing to have a Holi walk (not Holy walk) on Thursday 24-3-16. He will put up the proposal and if anyone wishes to join pl co-ordinate with Ranjit";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}