import re
regex = re.compile(r"(.*?)\s(\d{1,2})(?::(\d{1,2})(?:-(\d{1,2})?)?)?")
test_str = "2 Timothy 28:10-11"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")