# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(\w*?)>.*<.*>"
test_str = ("<soapenv:Envelope...>\n"
" <soapenv:Header/>\n"
" <soapenv:Body>\n"
" <urn:ClosedRequest>\n"
" <ExternalApplicationNumber>4816</ExternalApplicationNumber>\n"
" <PersonDataList>\n"
" <!--1 or more repetitions:-->\n"
" <PersonData>\n"
" <PersonExternalIdentifier>sa1</PersonExternalIdentifier>\n"
" <EligibilityEndDate>2017-12-31</EligibilityEndDate>\n"
" <!--Optional:-->\n"
" <ReasonCode>60</ReasonCode>\n"
" <PersonDeathDate>2015-09-02</PersonDeathDate>\n"
" </PersonData>\n"
" </PersonDataList>\n"
" </urn:ClosedRequest>\n"
" </soapenv:Body>\n"
"</soapenv:Envelope>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.