$re = '/\[[^\]]*\](*SKIP)(*F)|.+$/m';
$str = '[asdf]xxx
[foo]bar
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);