#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[+-](?:(a)|(bc))+(?:(a)|(bc))*+([+-x\/](?:(a)|(bc))+(?:(a)|(bc))*)*$"
Local $sString = "+a-bc-a" & @CRLF & _
"-bc+a-a" & @CRLF & _
"-b+a+ab"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)