import Foundation
let pattern = #"^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+a-bc-a
-bc+a-a
-b+a+ab
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)