re = /(?ix) (?:c \K) | (?<=\G) .*? \K \w+/m
str = 'c =word &word 2-2=0
c 22 ^&*w0rd*
+word &word '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end