// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http(?:s?):\/{2}regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$").unwrap();
let string = "http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}