import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/{2}regex101\\.com\\/r\\/([a-zA-Z0-9]{6})(?:\\/(\\d+)?)";
final String string = "http://regex101.com/r/mH1fN5\n"
+ "https://regex101.com/r/fW0vZ2\n"
+ "https://regex101.com/r/wY0rM7/3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}