// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sm)(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$").unwrap();
let string = "+7(985)392-75-73(1152)
+7(985)392-75-73 доб.1152
+7(985)392-75-73 доб. 78135
+7(985)392-75-73 11522
+7(985)392-75-73
+7(985)392-75-73";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}