import Foundation
let pattern = ##"(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.·\s]*){0,30}$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##" ~!@#$%^&**hJ电费Dfd s是 的发送 到 · 水电费水"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}