# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[^>]+>)(\~data_([^<]+))(<[^>]+>)/\1<![CDATA[\2]]>\4/gi;t' <<< "<element>~DATA_04</element>"