import Foundation
let pattern = #"(<[^>]+>)(\~data_([^<]+))(<[^>]+>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<element>~DATA_04</element>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1<![CDATA[\2]]>\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)