#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<div class="some-class">(.*?)<\/div>"
Local $sString = "<div class="foobar">" & @CRLF & _
" <div class="myclass">some stuff, and " & @CRLF & _
" <div class="some-class">" & @CRLF & _
" some other stuff" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")