// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<div class="some-class">(.*?)<\/div>"#).unwrap();
let string = "<div class=\"foobar\">
<div class=\"myclass\">some stuff, and
<div class=\"some-class\">
some other stuff
</div>
</div>
</div>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}