Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\+?(1?)[\(\s]*([2-9]\d{2})[\s\)]*(\d{3})[\s-]*(\d{4})
/
g
Input 1
1
New
12345678900 514 706 0306 514 706-0306 (514) 706-0306 +1 514 7090306 15147060306