$re = '/^.*\/(\d+)/';
$str = 'http://restapi.testdrive.klarna.com/backoffice/traders/1152921504638663904';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);