#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^@[a-zA-Z0-9]+\s?[a-zA-Z0-9]*$"
Local $sString = "@foo bar" & @CRLF & _
"@fo12 o"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)