package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[if \s+ [^]]* ]
(?<content> [^[]*+ (?> (?R) [^[]* )*+ )
(?: \[elseif \s+ [^]]* ] \g<content> )*+
(?: \[else] \g<content> )?+
\[/if]`)
var str = `$string = '
[if true]
[if true]
[if false]
[else]
[/if]
[elseif false]
[if true]
[/if]
[else]
[/if]
[elseif false]
[/if]
[if false]
[if false]
[else]
[/if]
[else]
[if true]
[/if]
[/if]
';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}