import Foundation
let pattern = #"\s(?=[^\[]*\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"value": [
0,
38,
255,
255
],
"comment": "bright blue, entrance coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
0,
255,
186,
255
],
"comment": "bright aqua, water coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
32,
32,
32,
255]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)