#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im).*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?"
Local $sString = "function somefunc($param){" & @CRLF & _
"//begin_special" & @CRLF & _
"some code;" & @CRLF & _
"" & @CRLF & _
"//some comments" & @CRLF & _
"//end_special" & @CRLF & _
"some code;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")