re = /.*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?/im
str = 'function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end