// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im).*?(\/\/begin_special([^\x00]*?)\/\/end_special).*?").unwrap();
let string = "function somefunc($param){
//begin_special
some code;
//some comments
//end_special
some code;
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}