package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.?\d*)(h|m|s|ms|f|t)$`)
var str = `11
11s
11.1222s
33ms
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}