package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|<|\b)(\S+?\.com)(\b|>|$)`)
var str = `I am google.com`
var substitution = "<a href="https://$2" target="_blank">$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}