const regex = /(^|<|\b)(\S+?\.com)(\b|>|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|<|\\b)(\\S+?\\.com)(\\b|>|$)', 'g')
const str = `I am google.com`;
const subst = `<a href="https://$2" target="_blank">$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);