$re = '/(^|<|\b)(\S+?\.com)(\b|>|$)/';
$str = 'I am google.com';
$subst = "<a href=\"https://$2\" target=\"_blank\">$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;