re = /(^|<|\b)(\S+?\.com)(\b|>|$)/
str = 'I am google.com'
subst = '<a href="https://$2" target="_blank">$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result