$re = '/(?:([+]\d{1,4})[-.\s]?)?(?:[(](\d{1,3})[)][-.\s]?)?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9})/';
$str = '+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516
+1(1111
+()1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);