package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"([^"\\]*(?:\\.[^"\\]*)*)"|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'`)
var str = `"The Doors" "Peace Frog" "Down The Road" Bootleg "lol noth\"ing here" something rofl lol "wtf is going on" 'nope noe noe' "'''" "something's fishy here..." 'are we "sure that this will work?"'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}