import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"\\\\]*(?:\\\\.[^\"\\\\]*)*)\"|\\w+|'([^'\\\\]*(?:\\\\.[^'\\\\]*)*)'";
final String string = "\"The Doors\" \"Peace Frog\" \"Down The Road\" Bootleg \"lol noth\\\"ing here\" something rofl lol \"wtf is going on\" 'nope noe noe' \"'''\" \"something's fishy here...\" 'are we \"sure that this will work?\"'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}