# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([^\"\\]*(?:\\.[^\"\\]*)*)\"|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'"
test_str = "\"The Doors\" \"Peace Frog\" \"Down The Road\" Bootleg \"lol noth\\\"ing here\" something rofl lol \"wtf is going on\" 'nope noe noe' \"'''\" \"something's fishy here...\" 'are we \"sure that this will work?\"'"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.