import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(define:[^>]+>)(.*?)<\\/\\1";
final String string = "text\n"
+ "<define:dos> This string explains DOS.</define:dos>\n"
+ "<define:foo> This string explains Foo.</define:foo>\n"
+ "more text";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}