re = /^(.*\n){3}/m
str = 'Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA[XXXXXXXXXXXXXXXXXXX...until EOL
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end