Non-Capturing Group(?:demande|incident) demandethe literal text demande (case sensitive) incidentthe literal text incident (case sensitive) .*any character (except for line terminators), repeated any number of times
Group num_externe(?'num_externe'INC[0-9]*) INCthe literal text INC (case sensitive) *matches any number of characters from the set below:
0-9one character from 0 (4810) to 9 (5710)
.*any character (except for line terminators), repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
Nomthe literal text Nom (case sensitive) \s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Group ins_libl(?'ins_libl'.*\)) .*any character (except for line terminators), repeated any number of times
\)the literal ) (4110 / 518 / 2916)
.*any character (except for line terminators), repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
Villethe literal text Ville (case sensitive) \s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Group apt_localisation(?'apt_localisation'.*?) .*?any character (except for line terminators), repeated any number of times
\s*any whitespace character, repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
-the literal - (4510 / 558 / 2D16)
\s*any whitespace character, repeated any number of times
Demandeurthe literal text Demandeur (case sensitive) \s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Group apt_nom(?'apt_nom'.*?,.*?) .*?any character (except for line terminators), repeated any number of times
,the literal , (4410 / 548 / 2C16)
.*?any character (except for line terminators), repeated any number of times
,the literal , (4410 / 548 / 2C16)
Group apt_telephone(?'apt_telephone'.*?) .*?any character (except for line terminators), repeated any number of times
,the literal , (4410 / 548 / 2C16)
.*any character (except for line terminators), repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
Catthe literal text Cat (case sensitive) .any character (except for line terminators)
goriethe literal text gorie (case sensitive) \s*any whitespace character, repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Group tsy_lib(?'tsy_lib'.*?) .*?any character (except for line terminators), repeated any number of times
\s*any whitespace character, repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
\s*any whitespace character, repeated any number of times
-the literal - (4510 / 558 / 2D16)
.*any character (except for line terminators), repeated any number of times
Descriptionthe literal text Description (case sensitive) .*?any character (except for line terminators), repeated any number of times
:the literal : (5810 / 728 / 3A16)
\s*any whitespace character, repeated any number of times
Non-Capturing Group(?:\n.*)* *repeats the group contents below any number of times:
\na line-feed (newline) character (ASCII 10)
.*any character (except for line terminators), repeated any number of times
\s*any whitespace character, repeated any number of times
othe literal o (11110 / 1578 / 6F16) (case sensitive)
\s*any whitespace character, repeated any number of times
Group commentaire_externe(?'commentaire_externe'.*?) .*?any character (except for line terminators), repeated any number of times
\s*any whitespace character, repeated any number of times
\na line-feed (newline) character (ASCII 10)
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string