#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?# Pattern before filename" & @CRLF & _
" )(?:\[download\] )?Destination: (?#" & @CRLF & _
")|(?#" & @CRLF & _
" )\[download\] (?#" & @CRLF & _
")|(?#" & @CRLF & _
" )Adding metadata to \"(?#" & @CRLF & _
"))(?#" & @CRLF & _
")((?# CAPTURE GROUP: filename pattern" & @CRLF & _
" )\/?[^\/\\\n]+(?:\/|\\)(?# Capture first folder" & @CRLF & _
" )(?:(?#" & @CRLF & _
" )[^\n\.]*(?# Stop capturing if point, to check" & @CRLF & _
" )(?!\.f\d{1,4}\.(?:webm|mov|mp4))(?# Checking this is not a partial download" & @CRLF & _
" )\.(?# Can now capture the point" & @CRLF & _
" ))+(?#" & @CRLF & _
" )(?:webm|mov|mp4)(?#" & @CRLF & _
"))(?#" & @CRLF & _
")\n?"
Local $sString = "=============================" & @CRLF & _
" GOOD TESTS" & @CRLF & _
"=============================" & @CRLF & _
"[download] /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/BURGER KLEAN - 1080.mp4 has already been downloaded" & @CRLF & _
"[download] /root/.local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded" & @CRLF & _
"[download] /root/local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded" & @CRLF & _
"Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/Hi Anxiety: Lana Condor - 1080.mp4" & @CRLF & _
"[download] Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/#histoire #vrai #fyp #foryou #pourtoi #fyp - NA.mp4" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.webm" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.webm" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO.webm" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_123.webm" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_1.2.3.mp4" & @CRLF & _
"xxx Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov" & @CRLF & _
"xxx Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"" & @CRLF & _
"[Metadata] Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"" & @CRLF & _
"[Metadata] Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"" & @CRLF & _
"[Metadata] Adding metadata to "/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov"" & @CRLF & _
"[Metadata] Adding metadata to "/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov"" & @CRLF & _
"" & @CRLF & _
"Adding metadata to "C:\Users\Adrien\AppData\Local\ICONO\ICONO_TESTS\1678715744635004900_0.6505223019081934\yt-videos\BURGER KLEAN - 1080.mp4" & @CRLF & _
"" & @CRLF & _
"=============================" & @CRLF & _
" BAD TESTS" & @CRLF & _
"=============================" & @CRLF & _
" def test_download(browser: Chrome):" & @CRLF & _
" app_actions = AppActions(browser, test_name="test_download")" & @CRLF & _
" app_actions.screenshot()" & @CRLF & _
" for url in url_to_test:" & @CRLF & _
" file_path = app_actions.download_video(url)" & @CRLF & _
"> assert os.path.isfile(file_path)" & @CRLF & _
"E AssertionError: assert False" & @CRLF & _
"E + where False = <function isfile at 0x000002D095AFF160>('C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.f248.webm')" & @CRLF & _
"E + where <function isfile at 0x000002D095AFF160> = <module 'ntpath' from 'C:\\Users\\Adrien\\mambaforge\\envs\\ICONO-prod\\lib\\ntpath.py'>.isfile" & @CRLF & _
"E + where <module 'ntpath' from 'C:\\Users\\Adrien\\mambaforge\\envs\\ICONO-prod\\lib\\ntpath.py'> = os.path" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.webm" & @CRLF & _
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.mov" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.1% of ~ 966.70KiB at 43.60KiB/s ETA 00:22 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.3% of ~ 966.70KiB at 127.60KiB/s ETA 00:07 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.7% of ~ 966.70KiB at 291.21KiB/s ETA 00:03 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 1.6% of ~ 966.70KiB at 610.67KiB/s ETA 00:01 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 3.2% of ~ 966.70KiB at 1.21MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 6.5% of ~ 966.70KiB at 2.30MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 13.1% of ~ 966.70KiB at 4.33MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 26.4% of ~ 966.70KiB at 8.06MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 52.9% of ~ 966.70KiB at 14.72MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 25.08MiB/s ETA 00:00 (frag 0/1)" & @CRLF & _
"DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 24.67MiB/s ETA 00:00 (frag 1/1)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")