import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:^|[^\\\\])(?:\\\\\\\\)*)(([`'\"])(.*?(?:[^\\\\](\\\\\\\\)*|$)(\\2|$)))";
final String string = "\"I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge.\"\\n\"That is my opinion too,\" said Ned Land, coolly. \"Let us wait for night.\"";
final String subst = "<span>$1</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}