Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=(?:^|[^\\])(?:\\\\)*)(([`'"])(.*?(?:[^\\](\\\\)*|$)(\2|$)))
/
g
Input 1
1
New
"I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge."\n"That is my opinion too," said Ned Land, coolly. "Let us wait for night."
Substitution
<span>$1</span>