import re
regex = re.compile(r"(?<=(?:^|[^\\])(?:\\\\)*)(([`'\"])(.*?(?:[^\\](\\\\)*|$)(\2|$)))")
test_str = "\"I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge.\"\\n\"That is my opinion too,\" said Ned Land, coolly. \"Let us wait for night.\""
subst = "<span>$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)