import Foundation
let pattern = #"(?<=(?:^|[^\\])(?:\\\\)*)(([`'"])(.*?(?:[^\\](\\\\)*|$)(\2|$)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""I do not know; but, whatever it is, it will be sunk before night. In any case, it is better to perish with it, than be made accomplices in a retaliation the justice of which we cannot judge."\n"That is my opinion too," said Ned Land, coolly. "Let us wait for night.""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)