import Foundation
let pattern = #"""
(?<IntKey>[^\s<>{}]+)\s*<(?<IntValue>\d+)>|
(?<TrueKey>[^\s<>{}]+)\s*<yes>|
(?<FalseKey>[^\s<>{}]+)\s*<no>|
(?<StrKey>[^\s<>{}]+)\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\s<>{}]+)\s*\{|
(?<ObjectEnd>\})|
(?<KeyOnly>[^\s<>{}]+)|
(?<Invalid>\S+)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
servername {
store {
servers {
* {
value<>
port<>
folder<C:\windows> monitor<yes>
args<-T -H>
xrg<store>
wysargs<-t -g -b>
accept_any<yes>
pdu_length<23622>
}
test1 {
name<test1>
port<123>
root<c:\test>
monitor<yes>
}
test2 {
name<test2>
port<124>
root<c:\test>
monitor<yes>
}
test3 {
name<test3>
port<125>
root<c:\test>
monitor<yes>
}
}
senders
timeout<30>
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)