$re = '/[].+.[].+/m';
$str = 'text cust.main.city here
cust.main.city text here
text here cust.main.city
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);