re = /[].+.[].+/m
str = 'text cust.main.city here
cust.main.city text here
text here cust.main.city
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end