package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Subject\:)(?:[\r\n]{2})(?<Subject>.+)`)
var str = `Subject:
Object reference not set to an instance of an object.
Created On (UTC): 6/26/2017 3:03:03 PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}