import re
regex = re.compile(r"(?s)(?:\G(?!\A)|^(?=.*WORD1)(?=.*WORD2)).*?\n\K(?-s).*WORD2")
test_str = ("Report Name\n"
"Report Date\n"
"Blah blah blah\n"
"Blah: WORD1\n"
"Blah blah\n"
"blah blah: WORD2\n"
"blah blah\n"
"Report Name\n"
"Report Date\n"
"Blah blah blah\n"
"Blah: WORD1\n"
"Blah blah\n"
"blah blah: WORD2\n"
"blah blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")