import Foundation
let pattern = #"\b(?!SaaS)(?i)saas\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SaaS
Saas
SaAs
SaAS
SAas
SAaS
SAAs
SAAS
saas
saaS
saAs
saAS
sAas
sAaS
sAAs
sAAs
It's SaaS, not SAas or saAS or sAAs, you dummy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)