$re = '/(?:\*.*\s)+/m';
$str = '## Title
This is some text hehe haha
* List starting here
* another list Item
* Maybe another
Here text again';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);